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GENERAL INFORMATION 

SCOPE  
This section describes the operation of the PXE7300 In-Flight Entertain-
ment system. Operating controls consist of two rotary knobs with push-
push switches, and four momentary buttons.  

Front Panel Controls 

Operating Controls 
The single-disk player is designed for simple operation. The Disc player 
will begin to play automatically when a Disc is inserted (unless the disc is 
specially formatted as 7300 volume, see section on special functions). The 
disc will play through in order, and then pause at the end.  If a disc is not 
inserted, the unit will be in the  FM radio mode. 

NOTE:  
When a disc is inserted, the display will show “Reading . . .” for up to 20 
seconds, depending on the media and amount of information contained. 

Power/Volume Control (1) 
The PXE7300 system is turned on and off by pushing the volume (left 
hand) knob.  
When the unit is first turned on, the green indicator lights should flash in 
sequence top to bottom and left to right (2, 3, 5, 4). 
The left knob is the volume control. Turning the knob clockwise will in-
crease the volume.  

Stop/Eject Button (2) 
The Stop/Eject button  will stop the disc. Hold for 3 seconds to eject the 
disc. 
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In AM or FM Radio Mode, this button scans up the frequency band for a 
strong signal. 
Play/Pause Button (3) 
Pressing the play/pause button momentarily will pause the player. Hold for 
about three seconds to advance the track. Hold this button continuously for 
an “intro” scan, which plays for a few seconds before moving on to the 
next track. Release to resume normal play. 
Momentarily pressing STOP/EJECT & PLAY/PAUSE buttons at the same 
time will cause the track to jump backward. 
In AM or FM Radio Mode, this button scans down the frequency band for a 
strong signal. 

Action Disc Result Radio Result 

▲short press Stop Frequency Scan Up 

▲ long press Eject (also in AUX) Frequency Scan up 

► short press Pause Frequency Scan Down 

► Medium press 
(3 sec) 

Select next track/file and 
keep playing or a random 
track if in the random 
mode 

Frequency Scan Down 

► Long press (> 
3 sec) 

Intro Scan, Plays first few 
seconds of each song, and 
advances 

Frequency Scan Down 

MODE press Change to FM, AM, 
AUX (if enabled) 

Change from FM to AM, to 
AUX to (if enabled) to DISC  

R/S press Toggle into Random or 
normal Sequence play 

Enter the preset “Set” mode 

DATA knob CW Select next track and play Increase radio frequency or 
preset channel 

DATA knob 
CCW 

Select previous track and 
keep playing 

Decrease radio frequency or 
preset channel 

DATA knob Push Show data on file (if 
available) 

Enter Pre-select Frequency 
Recall Mode 
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The R/S Button (4) 
This selects random play in the disc mode.  

The MODE Button (5) 
This button cycles through the operating modes, Disc, FM, AM, and AUX 
(if enabled).  

The Data Knob (6) 
In the Disc mode (CD or MP3), the knob will advance (CW) or decrease 
(CCW) the track. Track number is displayed when the knob is in motion. 
Then it will display the track name and then begin to play. 

In AM or FM radio mode, this knob can be used to tune the radio directly. 

If the playing media is an MP3 format, the pushing the DATA knob will 
display the available information (as stored) from the playing tracks in se-
quence when the knob is pushed. 
! Song Name 
! MP3 Actual File Name 
! Album  
! Artist 

Depending on the total size of the information stored on the disc, the avail-
able data may be truncated in the following manner: Small number of files, 
Actual File Name, Larger number of files, Truncated File Name, Most 
files, Track Number. 

Radio Preset Function 
The PXE7300 can save up to nine AM and nine FM frequencies for future 
recall. Select the desired radio frequency. 
To set press the “R/S” button (4). The next available slot will be displayed 
as “S#.” (# being the available memory location). Within five seconds, se-
lect the desired frequency using the DATA knob (if not already displayed). 
Press the R/S (4) again to save the selection. The display will flash, indicat-
ing a successful save. 
To access the channel, press the DATA knob (5) the radio mode, and select 
the preset with the DATA knob or scan up (2) and down (3) buttons. 

AM Radio Reception 
 The supplied passive AM/FM antenna, part number is optimized for FM 
radio performance. Therefore, when used for AM reception, the unit 
may only receive the most powerful 3 to 5 AM stations. In contrast to 
an ADF, where audio fidelity is not important, the PXE7300 requires 
higher signal levels to ensure fidelity. For optimum performance, 
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some users may desire an external AM/FM antenna. PS Engineering rec-
ommends a Comant CI-222-L. 

Pre-recorded File Playback (Option 1 only) 
The PXE7300 is designed to play up to five special files on a recorded MP3 
disc. This can be used for passenger briefing, tour narration, or other in 
flight uses. 
When one of the five inputs is triggered, a corresponding file on a specially 
encoded disc will start to play, regardless of the mode in use.  
When the file has completed play, the unit will return to the previous mode 
and track, but it will be paused.  
The special disc must be labeled as the volume 7300, and the tracks 
0001.MP3 through 0005.MP3. Other files, such as music, can be stored on 
this disc. The normal files will play, but files with the filename 0001.MP3 
through 0005.MP3 will not play unless the respective input is activated, OR 
specifically selected from the front panel. This section can be used to test 
the disc and determine which files are stored. 
See Appendix A for details on storing MP3 files.  

Display Dimming (7) 
The display is automatically adjusted for ambient light conditions by a pho-
tocell. The aircraft dimmer controls text backlighting. 

Appendix A MP3 Creation 

Creating MP3s from an Audio CD 
1. Start MusicMatch JukeBox.(www.musicmatch.com) Press the 

recorder button, which is the small red dot located in the top right 
corner. This will open the recorder window located at the bottom 
of the screen. 

2. Insert an audio CD into the CD drive. MusicMatch will automati-
cally read the disc and display the contents in the recorder win-
dow. Press the REFRESH button to check the Internet database 
for CD information, such as artist, song title, or album. If this 
information is available, it will automatically be updated in the 
file. 

3. Select Options->Recorder->Format and select either MP3 or 
MP3PRO format. You may also set the MP3 file quality under 
the Options->Recorder->Quality menu. 

4. Select the tracks to be copied to MusicMatch by checking the 
box next to the desired track. Press the record button in the lower 
left corner when complete 
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5. MusicMatch will then convert the files from the audio CD to 
MP3 and display them in the Music Library box located in the 
middle of the screen 

6. To edit the MP3 information, select a file in the Music Library 
and press the TAG button in the top right corner of the Music 
Library box. This will display the MP3 tagged information 
screen. Select the General tab to show the information that can be 
modified for the PXE7300. 

7. The PXE7300 can display song name, artist, album, and file-
name. This corresponds to the Track title, Artist, Album, and 
Track Filename fields shown on the screen. Each of these fields 
can be modified to the user’s preference. Note: The PXE7300 is 
limited to displaying up to 22 characters in each of these fields. 
Click on the appropriate field to modify the track title, artist, or 
album. To modify the filename, select the Rename Files button in 
the lower left corner. Click on the field labeled New File Name 
and press OK to change the file name. Press the Apply and OK 
buttons to update the information 

1.2 Creating Playback Files Using MusicMatch (Option 1 
Only) 

1. Create up to five MP3 files with the desired playback messages. 
These files must be named 0001.MP3 to 0005.MP3. File 0001 
corresponds to playback input 1, etc. 

2. Start MusicMatch JukeBox. Click the ADD icon in the Music 
Library window to bring up the file dialogue box. Select the files 
0001.MP3 – 0005.MP3 and click the ADD button. This will 
transfer a copy of the files to the Music Library. 

3. Select a file in the Music Library box and click on the TAG but-
ton to access the MP3 tagged information screen. Select the Gen-
eral tab to show the MP3 file information. Fill in the Track Title 
field. This information will be displayed on the PXE7300 when 
the file is active. This field may be up to 22 characters in length. 

4. Select File->Create CD to open the CD burner window. 
5. Select the MP3 disc icon to burn an MP3 disk. 
6. Double click on the Volume Name box, located to the right of 

the three disc types. Type 7300 in the window and press RE-
TURN to update the CD volume name.  

7. Select the ADD icon (+ sign) to open the file dialogue box. Se-
lect the files 0001.MP3 � 0005.MP3 and press the ADD button. 
Make sure these files are located in the root directory of the 
disc. Select any other MP3 files you wish to add to the disc. 
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Note: These files must not begin with a �000� prefix or the 
PXE7300 will play the incorrect tracks! Files can also be 
dragged from the Music Library box.  

8. Place the blank CD in the drive and select the BURN icon to 
burn the CD. 

Appendix B Error Codes 
Error code Description 
00 to 05 Timeout 

09 Manual Eject (Press Stop while powering on) 
21  command not defined 
22  illegal parameter 
23  sledge error 
24  focus error 
25  spindle motor error 
26  radial error 
27  PLL error 
28  subcode timeout error 1 
29  requested subcode not found error 
2B  toc read error 
2C  jump error 
2D  HF Error 
2E  CD decoder hardware error 
31  CA decoder data error 
32  CA decoder hardware error 
33  flash saving error 
34 Flash reading failure 
35 general system error 
36 loading decoder swap file error 
37 internal decoder communication problem 
38 internal memory filemap error 
80   loader error 
90   mechanism error / invalid media 

In the unlikely event that you insert an invalid disc media, a 
scratched or dirty disc, or the unit behaves abnormally, please 
consult the list of error codes.  
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Warranty and Service 
Warranty 
In order for the factory warranty to be valid, the installations in a certified aircraft must be 
accomplished by an FAA-certified avionics shop and authorized PS Engineering dealer.  If the 
unit is being installed by a non-certified individual in an experimental aircraft, a factory-made 
harness must be used for the warranty to be valid. 
PS Engineering, Inc. warrants this product to be free from defect in material and workmanship 
for a period of one (1) year from the date of installation as recorded in aircraft logbook and/or 
on FAA Form 337. During the twelve (12) months, PS Engineering, Inc., at its option, will 
send a replacement unit at our expense if the unit should be determined to be defective after 
consultation with a factory technician. 
All transportation charges for returning the defective units are the responsibility of the pur-
chaser. All domestic transportation charges for returning the exchange or repaired unit to the 
purchaser will be borne by PS Engineering, Inc. The risk of loss or damage to the product is 
borne by the party making the shipment, unless the purchaser requests a specific method of 
shipment. In this case, the purchaser assumes the risk of loss. 
This warranty is not transferable. Any implied warranties expire at the expiration date of this 
warranty. PS Engineering SHALL NOT BE LIABLE FOR INCIDENTAL OR CONSE-
QUENTIAL DAMAGES. This warranty does not cover a defect that has resulted from im-
proper handling, storage or preservation, or unreasonable use or maintenance as determined by 
us. This warranty is void if there is any attempt to dissemble this product without factory 
authorization. This warranty gives you specific legal rights, and you may also have other 
rights, which may vary from state to state. Some states do not allow the exclusion of limitation 
of incidental or consequential damages, so the above limitation or exclusions may not apply to 
you.   
All items repaired or replaced under this warranty are warranted for the remainder of the origi-
nal warranty period. PS Engineering, Inc. reserves the rights to make modifications or im-
provements to the product without obligation to perform like modifications or improvements 
to previously manufactured products. 

Factory Service 
The unit is covered by a one-year limited warranty. See warranty information 
above. Contact  PS Engineering, Inc. at (865) 988-9800 or www.ps-
engineering.com/support.shtml before you return the unit. This will allow the ser-
vice technician to provide any other suggestions for identifying the problem and 
recommend possible solutions.  
After discussing the problem with the technician and you obtain a Return Authori-
zation Number, ship product to: 

PS Engineering, Inc. 
Attn: Service Department 
9800 Martel Rd 
Lenoir City, TN 37772 
Phone: (865) 988-9800   FAX (865) 988-6619 

Email: support@ps-engineering.com 
NOTE: PS Engineering will not be responsible for any units shipped in the U. S. 
Mail. Units returned without either an RMA, or a detailed description of the prob-


